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Overview 
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 What is MS Excel? 

 Functions. 

 Sorting Data. 

 Filtering Data. 

 Data Form. 

 Data Validation. 

 Create charts in Excel. 

 Formatting Cells. 

 Conditional Formatting 

 Page Setup. 

 Printing Sheet. 

 

 

 

 

 

 

 



What is a MS Excel?  
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A spread sheet program 

 

  A spreadsheet is a computer application that simulates a paper 

worksheet.  

 It displays multiple cells that together make up a grid consisting of 

rows and columns, each cell containing either alphanumeric text or 

numeric values.  

 A spreadsheet cell may alternatively contain a formula that defines 

how the contents of that cell is to be calculated from the contents of 

any other cell (or combination of cells) each time any cell is updated. 

 Spreadsheets are frequently used for financial information because 

of their ability to re-calculate the entire sheet automatically after a 

change to a single cell is made. 
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Excel First Screen 
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Identify Excel Components 
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The active cell 

 Cell Address shows where the pointer is located in the worksheet 

 Cell Address is composed of Column Number followed by Row 
Number 

 For Example A1 means Column A and Row 1 

 Total Rows   :  65536 

 Total Columns  :  256 
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Work Book vs. Work Sheet 

 

 

 A workbook is a spreadsheet file. By default, each workbook in Excel 

contains three pages or worksheets.  

 

 The term spreadsheet is often used to refer to a workbook, when in 

actual fact, spreadsheet refers to the computer program, such as 

Excel.  
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Types of Data 

 Numeric (Numbers only)  

 

 Alphabetic(A single letter or String) 

 

 Alphanumeric(Letters and Numbers together) 

 

 Dates (Calendar) 

 

 Formula (Arithmetic operations ex. + - * / ^) 

 

 Function (Simple or Complex data operation ex. Sum Max Count 

..etc)  
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Functions 

 Excel supplies more than 350 functions organized into 10 categories: 

 Database, Date and Time, Engineering, Financial, 

Information, Logical, Lookup, Math, Text and Data, 

and Statistical functions. 

 

 You can use the Insert Function button on the 

Formula bar to select from a list of functions. 

 

 A series of dialog boxes will assist you in filling in 

the arguments of the function and this process also enforces the use 

of proper syntax. 
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fx marks the spot! 

 Office Excel 2007 offers two methods to insert 

predefined functions into your spreadsheet …. 

 The first method is the use of the Function Button 

next to the Formula Bar: 
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fx marks the spot! (Cont) 

 The second method is the use of the Formulas tab and the Function 

Library: 
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Inserting a Function 
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Functions YOU should know 

Statistical Functions 

 

 MAX - find the greatest value in a range. 

 

 MIN - find the lowest value in a range. 

 

 AVERAGE - determine the average within a range (sum divided by 

number of values). 

 COUNT - determines the number of cells in a range containing a 

numeric value (counts them). 

 COUNTA - counts the cells with text as well as 

numeric values (non blank cells). 
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Functions YOU should know 

Arithmetic Functions 

 SUM - syntax method: 

 

1. Locate the pointer in the cell where you need the sum 

 

2. Type =Sum( 

 

3. Select the range of numeric values either through pressing 
Shift+Cursor key or dragging the mouse pointer. Cell addresses of 
the selected range will be displayed as A3:C3 

 

4. Type ) and press Enter key to complete the formula. Sum will be 
shown immediately after pressing the Enter key. 
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 SUM - Excel function method: 

1. Enter the following data into cells D1 to D6: 114, 165, 178, 143, 130, 

165. 

2. Click on cell D7 - the location where the results will be displayed. 

3. Click on the Formulas tab of the ribbon menu. 

 

15 

http://spreadsheets.about.com/od/s/g/spreadsheet_def.htm
http://spreadsheets.about.com/od/s/g/spreadsheet_def.htm
http://spreadsheets.about.com/od/s/g/spreadsheet_def.htm
http://spreadsheets.about.com/od/s/g/spreadsheet_def.htm
http://spreadsheets.about.com/od/s/g/spreadsheet_def.htm
http://spreadsheets.about.com/od/r/g/Ribbon.htm


4. Choose Math & Trig from the ribbon to open the function drop down 

list. 

5. Click on SUM in the list to bring up the function's dialog box.  
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6. In the dialog box, click on the Number1 line. 

7. Drag selected cells D1 and D6 in the spreadsheet. 

8. Click OK. 

9. The answer 895 should appear in cell D7. 
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 STDEV - function estimates standard deviation based on a sample 
(range of numeric values). 

 

 Locate the pointer in the cell where you need to calculate the 
standard deviation.  

 

 Type =STDEV( 

 

 Select the range of numeric values either through pressing 
Shift+Cursor key or dragging the mouse pointer. Cell addresses 
of the selected range will be displayed as A3:E3 

 

 The formula looks like =STDEV(A3:E3) 

 

 Press Enter key.  

 

 Result is shown immediately after pressing the Enter key. 

 18 

http://spreadsheets.about.com/od/s/g/spreadsheet_def.htm


 SQRT - function is used to calculate square root of a number. 

 

 Locate the pointer in the cell where you need to calculate square 
root 

 

 Type =SQRT( 

 

 Select the cell for which square root is calculated for example cell 
A3.  

 

 The formula looks like =SQRT(A3) 

 

 Press Enter key.  

 

 Calculated square root value is displayed immediately after 
pressing the Enter key. 

 
19 

http://spreadsheets.about.com/od/s/g/spreadsheet_def.htm


 SIN - function is used to find the Sine trigonometric ratio of an 
angle. 

 

 Click on the cell where SIN value is required 

 

 Type =SIN( 

 

 Click on the cell (angle) for which Sin value is needed. The angle 
is considered in Radians =SIN(A3. If measurement unit of angle 
is degree, then the angle should be multiplied by Pi/180 as 
=SIN(A3*3.143/180  

 

 Type ) and press Enter key. Sin value for the given angle is 
displayed. 
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 COS and TAN - functions are used to find the cosine and tangent 

(trigonometric ) ratios of an angle respectively.  

 

 Method same as of SIN function 
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Functions YOU should know (cont) 

Logical Functions 

 IF - a decision making function used to determine the truth value for 

a condition. 

 

 AND - determines the truth value for a group of 

arguments as a whole (all must be true to be true) 

 

 OR - determines the truth value for a group of 

arguments separately (only one must be true) 
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IF General form:  

 

=IF(logical_test, value_if_true, value_if_false) 

 

 Locate the pointer in the cell where IF function is required. 

 

 Type =IF(D5>=50,"Pass","Fail") 

 

 D5 is the cell address whose value is compared with 50. If its value 
is greater than or equal to 50, the Pass is displayed otherwise Fail is 
displayed. 
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Percentage –  

 

Example: A student scores 453 marks out of 750, find %age result? 

 

1. Locate the pointer in the cell where you need the percentage 

2. Type = 

3. Click on the numerator value then type / 

4. Click on the value denominator value. The formula will look like 
=D18/E18. Now press Enter key 

5. To convert the result into percentage format, right click on the cell > 
format cells  > Number Tab > Percentage > OK 
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Tax –  

 

Example: A company imports some goods of SR 100,000. Find 3% Tax.  

 

1. Locate the pointer in the cell where you need the Tax amount 

2. Type =3/100* 

3. Click on total amount, the formula is shown as =3/100*D21 

4. Press Enter key, 3% tax of the total amount is displayed. 
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Sorting Data 

Sorting data means rearranging records in ascending or descending 
order based on any Field / Column 

 

 TO sort the data do the two steps: 

 select data in worksheet to be sorted. 

 from the Data tab ,select either : 

 Ascending 

 Or Descending  
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Multiple key sorting 
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Filtering Data 

Filtering is a quick and easy way to find and work with a subset of data 

in a range. A filtered range displays only the rows that meet the 

criteria 

  

 Unlike Sorting ,Filtering doesn't rearrange a range –filtering 

temporarily hides rows you don’t want displayed.  

 

 TO filter the data do the two steps: 

 select data in worksheet to be filtered. 

 from the Data tab ,select Filter 
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 By using Text Filters, you can specify a condition [to filter data by] 

that would normally take a great deal of time when you use the 

simple sort /remove method. 
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Data Form 

 Excel can generate a built-in data form (data form: A dialog box that 

displays one complete record at a time. You can use data forms to 

add, change, locate, and delete records.) for your range. The data 

form displays all of your column labels in a single dialog box, with a 

blank space beside each label for you to fill in data for the column. 

You can enter new data, find rows based on cell contents, update 

existing data, and delete rows from the range.   

 

 Microsoft chose not to include the Form button on the ribbon in Excel 

2007.  

 

 The first step to using the data entry form, therefore, is, to add the 

Form button to the Quick Access Toolbar so that we can use it. 
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Data Form (cont) 

 Add the Data Form to the Quick Access Toolbar. 

 

 Click on down arrow at the end of the Quick Access Toolbar to open 

the drop down menu. 

 

 Choose More Commands from the list to open the Customize the 

Quick Access Toolbar dialog box. 

 

 Click on down arrow at the end of the Choose 

 commands from line to open the drop down menu. 
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Data Form (cont) 

 

 Choose All Commands from the list to see all the commands 

available in Excel 2007 in the left hand pane. 

 

 Scroll through this alphabetical list to find the Form command. 

 

 Click on Add button between the command panes to add the Form 

command to the Quick Access Toolbar. 

 

 Click OK. 

 

 The Form button should now be added to the Quick Access Toolbar. 
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Data Form (cont) 

 Select records (range of data). 

 Click on the Form button.  

 A form is displayed containing all the fieldnames. You can add, 

delete, or find  records. 

 

34 



Data Validation 

Ensuring valid data entry is an important task. You may want to restrict 

data entry to a certain range of dates, limit choices by using a list, or 

make sure that only positive whole numbers are entered. Providing 

immediate help to instruct users and clear messages when invalid 

data is entered is also essential to make the data entry experience 

go smoothly.    
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 Select one or more cells to validate.  

 On the Data tab, click Data Validation, and then click the Settings 

tab. 

 To specify the type of validation that you want, do one of the 

following: 

 Any value, whole number, decimal, List, Date, Time, Text Length or Custom 

 In Custom, any criteria can be given e.g. >=3000 
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Create charts in Excel 

 Charts, or graphs, provide visual representations 

of the data. 

 

 A chart may be embedded in an existing worksheet, or can be 

created on a separate chart sheet with its own tab in the workbook. 
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Creating a chart 
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Method of chart creation 

1. Select the data range (same as data series). 

 Tip: Including Column Headings will save you time. 

 

 

 

 

 

 

2. Select the chart type. 

3. Insert and designate the chart location. 

4. Choose the chart options. 

5. Change the chart location and size. 
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Chart in sight 
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Formatting Cells 
The arrangement of data for storage or display is called formatting. To 

format cell(s), select the cell(s) to be formatted and follow the 
steps: 

1. Right click on the selected cells and select the Format cells menu 
item. 

2. The following dialogue box is displayed , you can configure all 
formatting options and press the Ok button. 
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Formatting Cells (cont) 
There are six tabs in the Format Cells dialog box: Number, Alignment, Font, Border, 

Patterns, and Protection.  

1. Number Tab: This tab contains options regarding formats of numbers. These are 
General, Number, Accounting, date, time, Percentage, Fraction, Scientific, text, 
Special and custom. By default, the general format. The user can select any 
format as per requirement. 

2. Alignment Tab:  It contains options to align text horizontally (left, center, right, 
justify etc), vertically (left, center, right, justify etc), orientation of text, merging of 
cells etc. 

 

 

 

 

 

 

 

 

3. Font Tab: Here the user can select a specific font type, size of text, colour and 
underline text etc. 
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Formatting Cells (cont) 
4. Border Tab: To surround the cells with border (lines), border option is used. It 

contains line types, lines colors, and options to draw border on left, right, top and 
bottom etc. 

 

 

 

 

 

 

 

 

 

 

 

5. Fill Tab: It has the patterns and colors shown in the dialogue box. 

6. Protection Tab:  It has two options Locked and Hidden but these options work only 
when the worksheet is protected. To protect the sheet, click on Review tab > 
Protect Sheet 
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Conditional Formatting 
Conditional Formatting is based on fulfillment of a condition. f the condition is true, 

formatting takes and no action otherwise.  

1. Select the cells in which conditional formatting is required.  

2. Click the Conditional Formatting button under the Home tab, Styles section.  

3. Select your rules. For this example,. The rule was that any text Equal to SR was 
red. 
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Here is what a portion of the finished 

spreadsheet looks like. 



Page Setup 

 Under the Page Layout tab.. You’ve noticed that a lot of the options 

are there as separate buttons, allowing you to quickly set one aspect, 

without the need for the Page Setup dialogue box.  

 

 if you really need to get into the Page Setup dialogue box: 

 Under the Page Layout tab ,A Page Setup section on the ribbon have a little 

arrow in the bottom right hand corner of the section , click on the arrow ,the 

page setup dialogue box was displayed. 
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 The page setup dialogue box 
contains four tabs i.e., Page, 
Margins, Header/Footer and 
Sheet.  

 

 Page Tab: In Page Tab, 
orientation(i.e., Portrait / 
Landscape), Scaling and Paper 
Size can be selected. 

 

 Margins Tab: Margin means the 
blank space from any edge to the 
text. Margins are on all four sides 
i.e., Top, Bottom, Left and Right. 
Other than these four, margin from 
header and margin from footer 
can also be adjusted. 
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 Header/Footer Tab: In Microsoft 
Excel, headers and footers are 
lines of text that print at the top 
(header) and bottom (footer) of 
each page in the spreadsheet.  

 

 In Excel, Header and footer both 
areas are divided into three i.e., 
Left Section, Center Section and 
Right Section. In these section 
the user can type any text like title 
and insert page#, time date etc.   

 

 Write your text in the desired 
left/center/right section(s) and the 
click OK. 
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 Sheet Tab: This tab 
contains four major 
options: 

 Print Area: A Particular area 
in the sheet can be selected 
for printing. When print 
command is given, complete 
sheet is not printed, only 
selected area is printed. To 
select Print Area click on      
in front of Print Area. Then 
select rows and columns and 
click on  
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 Print Titles: Here you can select the rows/columns to be repeated in every 

page. Procedure is same is above for print area. 

 

 Print: Here are different options to print gridlines, row and columns headings 

etc. These are turned on/off as per requirements. 

 

 Page Order: There are two main options: Down, then over mean the pages 

are printed from top to bottom and the next series is started if there are 

horizontally more pages in the sheet. Over, then down means that 

horizontally all pages are printed first and vertically next series is started 

then. 
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Printing Sheet 
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 The Print dialogue box is displayed. It 
contains five important options Printer, 
Properties, Print Range, Copies and Print 
What: 

 Printer: From here you can select printer of 
your own choice among the printer installed 
on your computer. 

 Properties: Properties of printer like paper 
size, quality of output etc. are set from here. 

 Print Range: Print range means how much 
pages of sheet are required to be printed 
i.e. all pages or some pages. 

 Copies: Copies means how much times the 
same page to be printed. 

 Print What: It contains three options i.e. 
Selection (selected area of sheet is printed 
only), Entire workbook (all sheets of 
workbook are printed) and Active Sheet (the 
sheet which is active that is printed only.) 
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The End……… 
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